Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Im trying to upgrade to 8207. So far, my testing has been...


john cullen

Recommended Posts

Im trying to upgrade to 8207. So far, my testing has been light, but I have stumbled into a few problems.

I am curious if you are willing to post some of the problems you have seen.

I have three problems in particular I have found.

HOLD FORMAT SQL_SCRIPT, used with join, generates invalid SQL.

HOLD FORMAT FOCUS with a long LRECL, generates different segment names for a fieldname.

A documented example of WITHIN doesnt work in 8207 (works in 8203)

The other problems I have seen, so far I can workaround.

Curious what problems you have seen with 8207.

Link to comment
Share on other sites

Hey John

For us, we mostly hit syntax tightening problems. At my current customers site, they installed WF using a sql server repository and felt the need to keep the database set for Case Insensitive.

A bunch of my issues are around case mismatches.

But -one that Ive got a case open on for over a year is a simple UC.

This is a situation where using a fully qualified IBFS path in a stylesheet - where the stylesheet is pointing to EDASERVE, the file is not found.

Simple enough to work around, just go back to the old appfolder/mysheet.sty to get it to work.

I just went back to look. I reported this in november of 2019.

After digging in a lot, I found it was one particular setting in edaserve.cfg that makes this error show up:

[Adapters]

mss_access = y

mss_rel = 2012

wfcr_access = y

Long as youre not using that client rest services business, it works for some reason.

Hit some BIP conversion issues too, but not sure if those are strictly 8207 related.

Several of us are doing 8105m->8207.

Link to comment
Share on other sites

  • 3 months later...

sharing a few problems we found.

COMPUTE fieldname = CNT.DST. caused crashed agents.

All the htmlforms had to be refreshed in 8207.

InfoAssist focexecs with FOCCACHE had issues opening. Seems related to data preview.

prefix operators now appear in titles. (this changed in 8205) MAX,fieldname is the new title.

IA grouping tool issues

reportcaster added CC distribution name to the schedule ( happened twice)

iapreferences.xml file corrupt. (there is a bat file to run ot fix this)

default/theme.sty missing stylesheet.

had to raise the derby java_opts memory to run dbreplicate

we have 1000s of broken pipe error messages in event.log

a few that I can think of.

Link to comment
Share on other sites

With 8207v27 version:

 

 

As stated by jnc, all HTML pages have to be reopened and their parameters re-mapped (refreshed)

 

 

Refresh button from an HTML page does not refresh (clear) a calendar control selection (should be fixed in further release)

 

 

Custom multiselect Drop down list that include an All option in its data (data built from a fex where All (_FOC_NONE) is added) allows to select All and other options at the same time

 

 

Custom java script in HTML pages may not work as expected since now all internal reference to a radio/check box options are no longer using the numbering syntax such as checkbox1_0, checkbox1_1, checkbox1_2,

So using something such as:

if (checkbox1_1.checked == true) {}

will not work and has to be replaced by (assuming a single option in checkbox1 where its set to Y when checked/selected)

var check1 = IbComposer_getCurrentSelection(checkbox1);

if (check1 == Y) {}

 

 

Designer (from at least 8207v22 and forward) can no longer edit a graph created with AppStudio from previous releases (pre 8207)

 

 

AppStudio 8207v22 and forward, dont anymore have the option to create graph, must use Designer

Link to comment
Share on other sites

We are trying to upgrade from 8202 to 8207.27.

 

 

I also have a case open for the default/theme.sty missing stylesheet. I am not sure how to create this stylesheet and why it is needed.

 

 

We have some reports that when you open in IA, they hang and the cpu consumes an additional 20-25% and never releases. We have to close the browser and start again. So after opening 4-5 of these reports in IA, the cpu is maxed and I have to restart Tomcat. Case has been opened. Actively working with TIBCO on this case.

 

 

We have some reports that when run they crash an agent. Under investigation but no culprits. CNT.DST. not used in report.

 

 

There is one report we found so far that when you open it up in IA, the Defines are rearranged automatically which causes the report to error when it is run. Looks like multiple DEFINE/END statements are generated when it was just one before it was opened in IA. Case open.

 

 

We are not able to schedule a bursted report using a distribution list from the repository. Works ok when the same distribution list fex is on the server. Generates the message: (FOC295) A VALUE IS MISSING FOR: &FOCEXURL. Case opened.

 

 

Creating a new report using IA automatically adds SET KEEPDEFINES=ON. I believe the default is OFF. I dont understand where this is coming from.

 

 

sql_script hold files (not BINARY, not FOCUS) created fieldnames in all uppercase. This one was solved. Added SET HOLDNAMES=MIXED in edasprof.prf.

Link to comment
Share on other sites

Todd, we are sharing similar problems.

the one that is killing me right now is when you save a complex IA report, it is writing defines to the wrong block, putting joins out of order. Restated, the report opens in IA, you think you are updating your report, and when it writes out the code, everything is jumbled. Joins in the wrong spot, defines combined. Now you have a report that doesnt run and you cant edit in the GUI. It is a MESS. I likely have 100s of reports with this problem.

The missing stylesheet is mostly noise in the logs. Were in the Tibco Cloud, so in my case, they are replacing the missing file.

Crashing agents is probably CNT.DST.

Link to comment
Share on other sites

The thing that has kept us from upgrading before (we are in the process of testing again) was some reports would give an unrecoverable error when you tried to open them with IA in 8207 (from 8203). This seems to be reports where a HOLD file does a DST or CNT on a defined field.

Im worried now about finding joins or defines out of order.

Link to comment
Share on other sites

We were on 8203, so we got the accumulated changes from 8205, which was a big server change. We had to wait for 8207, because of a JOIN SQL_SCRIPT problem (created invalid sql) introduced by not noticed by anyone else in 8205. We upgraded to 8207.26 client, 8207.27 server.

The jumbled fex problem of InfoAssist, I found out is already reported. Supposed to be already fixed, waiting for a release date. We didnt find this in our testing of 8207.

Link to comment
Share on other sites

3 of the largest issues with Designer Studio in 8.207 are :

 

Chaining of parameters has become quite challenging. This was super-easy in App Studio when chaining the parameters on a HTML page. More specifically the chaining of parameters derived from a hold file.

The screen resolution of graphs between a larger monitor to a smaller monitor is simply terrible. In App Studio there was an overall horizontal scroll bar on the HTML page which would keep the integrity of the graphs. In Designer Studio every single graph attempts to resize to the point where they are unusable.

Graphs built in App Studio are no longer editable. My take is in 8207.28 you will be able to edit the graphs in InfoAssist, but going forward you can no longer build new graphs in AppStudio.

Link to comment
Share on other sites

  • 2 weeks later...

Hello Todd, I have two variants that maybe you could try.

In IA, make a define, hold file, second hold, define, third hold, join the hold2, 3 to hold1, define on hold1, then report. See if that saves and reopens. sounds confusing but really not, just define on car, table file car, hold, repeat that twice for 2 more hold files, then join file1 to the other files, add a define, and report. for me in 8207.26, it saves the code out of order. My existing reports built in 8203 get corrupted when opened in 8207, and it has been a huge headache for us, because all end user reports cant be edited.

Another example is make an IA report, with a hold file called foccache/Main. For me, they wont reopen in 8207.

Link to comment
Share on other sites

  • 1 month later...
We have been struggling to get to 8207.27 from 8105 for a long time. Encountered several huge problems such as data models (cluster joins) which use master files from more than one connection do not work, even if they are both pointing to the same database server, and reports with multiple defines cannot be opened in Info Assist as it will split the defines into separate defines and cause the reports to fail. The multiple defines issue is supposed to be fixed in 8207.28 but I am having issues getting it installed as it appears to now require Java on the application client server to do the upgrade which has not be needed before. Also, binary hold files are handled differently which has also been causing a lot of problems. Retirement is looking better every day.
Link to comment
Share on other sites

  • 3 weeks later...

I have recently downloaded App Studio 8.2.0.7 to my laptop and we have the server version on our system servers. Most things from our perspective have gone smoothly, as I have tested all our current reports. Two issues I have, and I am hopeful to get some answers to them here, or please direct me to a place where I can get them.

One is that I seem to have unchecked the box on the install of App Studio to download the sample data like the CARS database and the like. Does anyone know if I can recreate those after the fact

The other is that we have about 10 reports that our users runs from their UI that are shown in Word format. When I ran those reports, the way they worked before the upgrade has changed with the new version. Things like having borders around the fields that our customer needs and placement of fields on the report dont work as before.

I have been able to resolve most of the issues except for a few I am still trying to tweak. The kicker with these reports are that they are saved like this - ON TABLE HOLD AS ROUTPUT FORMAT HTMTABLE then they use HTMLFORM BEGIN and END with styling in that code section. But just prior to that we do this command: SET HTMLFORMTYPE=DOC.

For example one report uses SUBHEADs and a CLASS= variable on the stylesheet that references that style in the HTMLFORM section - it seems as though the CLASS variable isnt working as expected for a SUBHEAD - not sure where to go for help wit this. Any help would be appreciated.

Here is an example of the stylesheet: TYPE=SUBHEAD,BY=XXXXXXXX,LINE=4,OBJECT=TEXT,ITEM=1,JUSTIFY=CENTER,COLSPAN=4,CLASS=tHeading5,$

and the class in the section below it looks like this .tHeading5 {border: 1px solid; text-align: LEFT;}

Lastly, since our data is classified I cant give my code using our data and that is why I need to get the sample databases back so I can use that data to show as examples of the problem.

Thanks for looking.

Paul Mueller

Federal Reserve Bank of St. Louis

paul.a.mueller@stls.frb.org

Link to comment
Share on other sites

Contracting to a client where the WF servers are still on the mainframe - z/os

Upgrading from 7702/3 to 8207.28

All custom handcoded html/javascript/fexes and just moving out of IE 11 (compatibility mode). The biggest issue we have had is sloppy coding in HTML and javascript.

(ex: htmlform begin without end and referring to a form name that wasnt named)

There is a issue that has been fixed in 8207.28 that if you execute a MORE and the MORE has no data, it would crash the agent.

The other issue also fixed in 8207.28, is that if the spreadsheet (excel and exl2k) are created as binary, the record length was set to zero which creates an unreadable file on the mainframe. In order to email the file, the client converts the file to bit 64, which works until you cant read the file to convert.

Lori

Link to comment
Share on other sites

Using 8207v28 have an issue with the Group Box legend in HTML document.

Previously displayed as

 

Now displayed as (on execution)

 

The legend does not overlay the border with a transparent background.

Even playing with background color/transparency has no effect to retreive previous display.

Issue occurs only with modern browsers.

Case open.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...