Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

App Studio - Unspecified Error Upon Attempting to Close


David Briars

Recommended Posts

Normally I will see the dialog box 'Do you want to save the changes to the file x?', when I go to close an Edit Text canvas that I have updated, but not yet saved:  

image.png.ec769e8a046405aa03f53add8825dd2c.png

 

After using App Studio 'for a while' I will see an 'Unspecified error' OK Box, when I go to close an Edit Text canvas that I have made changes to:

 

image.png.1f943b3cdeef0eeef4d03f9fd87da5ff.png

 

This rogue OK Box forces me to quit App Studio, or click undo, if I do not want to save a fex that I might have updated.  

We are on v8207 of App Studio.  

This doesn't only happen to me, it happens to others at my site. 

Any assistance gratefully accepted.

Link to comment
Share on other sites

@David Briars 3 -  this could be caused by a timeout of your session - if error occurs - can you try to run any report and see what happens?

In addition you can try to use the AppStudio Trace tool to debug - https://docs.tibco.com/appstudio/8207/doc/html/index.jsp?topic=%2Fcom.ibi.help.apps%2Fsource%2Ftroubleshooting88.htm 

Please open a case with support.tibco.com 

 

Link to comment
Share on other sites

Thanks for your thoughts Patrick.  

It does feel like a timeout issue.  

However, where or how the timeout is occurring isn't clear.  🤔

I did try running another report while in 'Unspecified Error' mode, but that did not alleviate the rogue OK box.  

Link to comment
Share on other sites

@David Briars multiple root causes - if  you are not activly saving openening navigating  in AppStudio this could cause a timeout - by default timeout is 2 hours. Alrenative problem multiple AppStudio on the same machine using internet explorer in parallel to access WebFOCUS .

how long is your timeout period?

Link to comment
Share on other sites

A little hard to say precisely what the timeout period is, if only cause I haven't set a timer yet, but I would say '2 hours' is a very reasonable guestimate of what I am experiencing.  

Is the default timeout of 2 hours something I can change?

Thanks for your thoughts Patrick.    

 

Link to comment
Share on other sites

Posted (edited)

Thanks Martin.  Yes, I wasn't sure how/if a Portal Setting like Session Timeout would effect an App Studio user either. 

Maybe Patrick can clarify?  

Yes, I had dropped the App Studio 'Ping Interval' setting from the default of 5 to 1 previously. 

And even with this change I still obtained the rogue 'Unspecified Error' message in place of the 'Do you want to save the changes...' message, about two hours into my App Studio session.  

Edited by David Briars
Link to comment
Share on other sites

1 hour ago, David Briars said:

Thanks Martin.  Yes, I wasn't sure how/if a Portal Setting like Session Timeout would effect an App Studio user either. 

Maybe Patrick can clarify?  

 

AppStudio is using the same way to communicate with WebFOCUS than the regular browser - and portal setting might be misleading - it#s any session that uses the portal/hub logon.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...