Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

On 8202M. Today I used App Studio to refresh a synonym. Th...


Todd Van Valkenburg

Recommended Posts

Well, never mind. Need more coffee After the refresh, I was looking at the Field View tab and the column displayed on that tab is the Usage Format rather than the Actual Format. So, looking at the Text View, I see that the actual format was updated by the refresh. So now it is up to me to update the usage format since they are now different.

Todd

Link to comment
Share on other sites

On 8202M. Today I used App Studio to refresh a synonym. The backend Oracle database has some existing columns that are now different (e.g. char 20 instead of 10) from the existing metadata. What I expected from the refresh was to have the table reflect the columns that are in the Oracle database. However, what I experienced was that all the columns that are different than Oracle appear in red and the synonym was not altered. Perhaps this is normal behavior and so I am just trying to understand this functionality. Or perhaps this is a bug. I should note that one column in the said synonym was altered in the past to correct the usage format for one of the fields. Also, there are existing reporting objects that reference this synonym.

I also signed on the to the Reporting Server and tried the same exercise there but the synonym did not change.

Thanks for your insights.

Todd

Link to comment
Share on other sites

Todd,

you may also need to check on reports that use the changed fields. We recently had a field change from numeric to alphanumeric format and the reports that used that field in filters broke. We had to put the format back to numeric, remove the field from the reports, then move forward with the change, adding the field back to the reports with the values in quotes.

Gotta have that coffee!

-Deb

Link to comment
Share on other sites

You could also take a look at Analysis Reports in the Reporting Server console. It has an Impact Analysis that tells you what fex is using the synonym. Theres also an Impact Analysis in App Studio where you can find all references to a synonym within the domains as well.

 

image.png969410 37.1 KB

Link to comment
Share on other sites

When I have tried the Impact Analysis (from App Studio and from Reporting Server), it only searches the Edaserve. But we do not store reporting objects in the Edaserve and rather use the Repository. But I cannot figure out how to change this behavior to run an impact analysis for a changed mas on the repository. Do you know how to do this by chance Thanks!
Link to comment
Share on other sites

On App Studio, expand Workspace or Domain, then right click the Workspace youd like to analyze. First item on the menu is Impact Analysis. When you click that, youll be running Impact Analysis on the content of that Workspace/Domain. However, you do have to pick the location of the synonyms on App Path. So, pick a path and then click Analyze to get a list of all the procedures using that synonym in the Repository.

 

image.png496771 67.9 KB

Link to comment
Share on other sites

  • 9 months later...

Hi Todd

Thats a drag. The only reference I found to a 12002 is from 2017 on focal point:

Error Parsing MASTER File SEP_LIST (The operation timed out (12002)).

So it appears to be timing out. I wish I was up to speed on app studio in 8207 but were still on 8105m right now. Think it would help to bump up your time limit on your connection to WebFOCUS There are a couple of places the timeout setting exists. Heres a pic from 8105m:

 

image.png613622 24.1 KB

 

Maybe this is why it fails for you but works for IBI

Link to comment
Share on other sites

Sorry guys - I hoped that would work. I had this problem years ago with Dev Studio at one client in particular and changing the timeout to be longer helped.

@todd.van.valkenburg - I presume they had you collect a communication trace. if they didnt, itd be worth looking at the network traffic to see if you can tell where things go wrong. Youd probably find the offending command right ahead of the timeout.

Im not sure where the trace program lives in 8207 - it used to be under appstudios bin folder.

C:ibiAppStudio81binWFSCOMTrace.exe

You might find something useful there.

You can also use whatever HTTP traffic capture tool you like - I used Fiddler quite a bit for this sort of thing.

IBI should have already asked you to collect one of these (I think).

Itd be interesting to see though.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...