Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

When running this focexec from MS Edge. TABLE FILE CAR "Act...


David Briars

Recommended Posts

When running this focexec from MS Edge.

TABLE FILE CAR

"Active Report/Export to MS Excel Test"

"As of &DATE at &TOD"

PRINT COUNTRY

CAR

ON TABLE PCHOLD FORMAT AHTML

END

 

and then clicking ExportXMLAll Records

 

image.png626555 18.3 KB

 

I see the data open in a new tab not in MS Excel:

 

image.png1879146 18.6 KB

 

If I run the same fex, from IE 11, and Export I see the data open up in MS Excel AOK:

 

image.png526660 34.5 KB

 

Any ideas on how to get the WebFOCUS Active Report Export to Excel functionality working in MS Edge

Link to comment
Share on other sites

Hi David

Sounds like a mime.wfs like issue (admin console / redirection), but Id think both browsers would do the same thing.

When I tried this, even though I say to Export to Excel with XML it actually prompts me to save a .xls file. If I save the file, I can open it after I get past a warning screen. Not real friendly.

A few thoughts to home in on the problem.

What version of WF are you using (like I tried 8207.17)

Is it only you that has this issue, or do other people with different PCs get different results

I did find one thing that might be useful but its from an 8.0 technique. You might check this out.

How to export Active Report (AHTML) to Excel .xslx file

Sorry I couldnt find more info. Ill be watching as this may come up for me too.

Thanks

Toby

Link to comment
Share on other sites

What happens when you go straight to XLSX Does ON TABLE PCHOLD FORMAT XLSX open properly In ie theres something about activeX but Im not sure if MS Edge has the same thing but it might be worth checking:

Export to Excel/xml works with IE11, if Initialize & script ActiveX

controls not marked as safe is enabled in the browser security settings.

(This is the same setting required for the earlier IE versions when used with

this Export feature.)

Link to comment
Share on other sites

frans:

 

Works fine for me in Edge Version 85.0.564.63 on WF 8206

 

 

Apologies for not listing my release information in my first post.

WebFOCUS: 8105M

MS Edge: 42.17134.1098.0

I see that Frans is using a much more recent release of MS Edge.

I believe his release includes Chromium, were as mine does not.

@Frans - Can you tell me if you are running MS Edge in IE mode

Perhaps, the Active Report Export functionality uses ActiveX, and ActiveX is only supported in IE mode of Edge

@All - Can anyone tell me if MS Edge support for the Active Report Export functionality kicks in, in the later releases of MS Edge

Thanks all!

Link to comment
Share on other sites

Thank you Frans.

Yep, I have a feeling the Active Report Export XML (Excel) function will work, once we are on a more current release of Edge.

Unfortunately, I dont have a way to test that yet, nor do I have a way to render under Chrome.

Yep, if a more current release of Edge still didnt work, I would look to run our WF site in Edge IE mode.

Link to comment
Share on other sites

  • 2 months later...

david.briars:

 

Yep, I have a feeling the Active Report Export XML (Excel) function will work, once we are on a more current release of Edge

 

 

My notebook was recently upgraded to MS Edge/Chromium 87.0 with IE mode on.

And with this upgrade from MS Edge 42.1, Active Report - Export - XML (Excel) is now working.

 

image.png987607 52.3 KB

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...