Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

I am executing the following code in 8207.28.07: TABLE FILE ...


David Briars

Recommended Posts

I am executing the following code in 8207.28.07:

TABLE FILE GGSALES

SUM DOLLARS

BY REGION

ON TABLE PCHOLD FORMAT AHTML

END

 

Pleased as punch with the Active Report goodness in MS Edge, I export the report to Excel:

 

image.png698548 16.9 KB

 

After the export, I click to open the export, and I spy with my little eye, the following Microsoft Excel warning box:

 

image.png1660650 52.9 KB

 

I click YES, and the workbook opens with my data from the Active Report.

Any ideas on how I can avoid the M$ Excel warning

Note: Our ON TABLE PCHOLD FORMAT XLSX reports open AOK, without any warning. It is only the direct export from the Active Report in the browser that is shaking its angry fist at me.

Link to comment
Share on other sites

Thank you for your offer to assist.

Adding ON TABLE SET AREXPEXCEL XLSX, had no effect on the Active Report EXPORT giving the Microsoft Excel Format error message.

 

As far as I can tell. the ACTIVE REPORT export code gives the export file a .xls extension. MS Excel is suspicious of that extension, and throws the warning message.

I cracked open the export file, and yeah, it doesnt look like a binary old style .xls file. (I can use an Old Style right about now. )

First few records of the export file:

<xml version="1.0">

<mso-application progid="Excel.Sheet">

<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"

xmlns:o="urn:schemas-microsoft-com:office:office"

xmlns:x="urn:schemas-microsoft-com:office:excel"

xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"

xmlns:html="http://www.w3.org/tr/REC-html40">

<DocumentProperties xmlns="urn:schemas-microsoft-com:office:office">

<LastAuthor>AHTML</LastAuthor>

 

I would love to have a more seamless UX for my users, by them not seeing the warning, and having to click through it.

Link to comment
Share on other sites

The error on the .xls extension is exactly what we run into.

There are two TABLE SETs (WEBVIEWER and AREXPEXCEL) and I left off WEBVIEWER. Sorry about that.

This is our solution:

 

TABLE FILE GGSALES

SUM DOLLARS

BY REGION

ON TABLE SET WEBVIEWER ON

ON TABLE SET AREXPEXCEL XLSX

ON TABLE PCHOLD FORMAT AHTML

END

Link to comment
Share on other sites

Thanks for the further assistance Bryan.

OK, after adding the ON TABLE SET WEBVIEWER ON to the TABLE FILE command, I needed (per the TIBCO HelpDesk) to set Excel Server URL to Reporting Server JSCOM on the Administration Console Client Settings page.

With that, the Active Report Export to Excel started to go to a .XLSX and not a .XLS file. And with that, cranky MS Excel stopped giving me a stern warning.

Unfortunately I am not in a position to add the WEBVIEWER SETting to our many Active Reports.

And if I add the setting higher up, like in a profile, it negatively effects our HTML formatted reports by showing, well, a web viewer.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...