Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Public Reports in Webfocus 9


Shawn Robbins
Go to solution Solved by Clayton Peacock,

Recommended Posts

This is similar to this thread, but I'm having the opposite problem.

We recently upgraded our system from Webfocus 8 to Webfocus 9. We had 2 reports that had public access, meaning that anyone could access them without going through the usual SSO process associated with our university. I've tried to copy all of the parameters and permissions from the old system exactly, but when trying to access these reports, it now requires going through the login process. Both reports are in the top "Reports" folder, which I believe is the public folder.  Our authentication is set up like this:

image.png.5de6aaf6ac995a5471e4e8838f4bf0fb.png

This is why I'm including the other thread, as I wasn't sure if having the anonymous authentication enabled meant there was an anonymous authentication problem or not. I've combed through the permissions and there doesn't seem to be any other issues, so any help with this issue would be apprecated.

Link to comment
Share on other sites

  • Solution

Check that your public user is active in security center and is in the Anonymous group. 

Stop All WebFOCUS + Tomcat service, delete below files:

  • E:\ibi\tomcat_980\logs
  • E:\ibi\tomcat_980\work
  • E:\ibi\WebFOCUS82\logs

Run public content after all services started and check WebFOCUS logs audit.log and event.log to see if you get any insights to the why you getting prompted.

 

Link to comment
Share on other sites

The reports were in the IBFS:/WFC/Repository/Public folder, so a yes on the repository part. Stopping the services, clearing the logs, and restarting seemed to do the trick! Looks like it just needed a chance to implement all the security changes I had made.

  • Like 2
Link to comment
Share on other sites

Yes. Entering the report path in the browser now allows anyone to run the reports. Still having some issues with the reports themselves being able to find/access the files they need to run, but public users can get to the reports and see them. 

  • Like 2
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...