Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Why do reports have "Restrict schedule to Library only" selected?

Cory Vendrely

Recommended Posts

I just created a new report, and I tried creating the schedule to email me results, but I noticed that "Report Library" was my only option to schedule. Then, I opened the report's Properties, and I found in the Advanced tab (at the bottom) that "Restrict schedule to Library only" was selected as default. I tried deselecting it and saving, but it keeps reselecting it after I save... This report doesn't seem to have anything unusual inside of it. I have never seen this before. I don't think anyone changed admin settings in our webfocus environment. Does anyone have any ideas? We are on version 9.1. Thanks.

Link to comment
Share on other sites

Hi Patrick. I checked the ReportCaster Configuration and everything matches what your screenshot shows.

I updated the Description of the report and saved it. That saved just fine.

I refreshed, cleared cached, signed out and signed in... Still having issues with the report library check box.

When I first created the report, and tried to schedule it, I only saw the "Report Library" option. No email option.

After that, I opened Properties, Advanced tab, and deselected the "Restrict schedule to Library only" box, and clicked Save.

The screen flashed briefly, and the "Restrict schedule to Library only" box re-selected itself.

Now, if I look at the schedule options for that report, I can see the other options... even though that check box is still selected.

image.png.fb5fa6e5a78c08afc2fa852b543cd021.png I cannot turn this off.


After seeing this, I skimmed through other reports to see if they have the same check box selected. Some do. It seems random...

I had another schedule that failed to email today because of this same issue. When I opened the Tasks tab in that schedule, it gave me an error message about "report library", but I didn't screenshot it (sorry)... I went into the report properties, deselected that check box, and that actually worked. I was able to run the schedule. But my other report will not let me deselect the check box. I'm not sure why some reports do and some don't. I also don't know why this happened all of a sudden. I have created many schedules over the past few years and have never seen this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...