Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

9.1 upgrade in place has problem


David Hall 5

Recommended Posts

We have been testing the new 9.1

We did a clean install, and it worked with no major issues

We did an upgrade in place from 9.03 to 9.1 and had issues

we did an upgrade in place from 8207.28.13 to 9.1 and had issues

symptoms basically show some of the features (like new workspace folder or role utility) cannot read zip file.

We discovered that the upgrade in place takes the webfocus.cfg file and modifies the syntax for file locations incorrectly. Instead of E:ibiapps for example the file location was modified to

E:/ibi/

CM import and export folder syntax is also messed up

Opened a case to report the issue, but changes made in the Admin Console GUI do not appear to work properly

Link to comment
Share on other sites

Hey David

I saw this too in 8207->9100 upgrade for APPROOT. Also noticed the same odd escape character in this entry:

IBI_DYNAMIC_LIST_PATH=IBFS:/WFC/Repository/Common

So even IBFS paths are getting that treatment

Now I'll also point out that the help file seems to suggest we should be using unix like forward slashes in our windows boxes:

APPROOT (IBI_APPROOT_DIRECTORY)

Specifies the location of the Application Namespace root directory used by the WebFOCUS installation. The default location is drive D:/455/ibi/apps, unless a different directory was specified during installation.

Also worth noting, I seem to be able to work just fine with this odd looking path name in the webfocus.cfg.

And in the admin console, it looks normal.

Even on my clean WF Integrated install, when I altered approot from it's default:

C:/ibi/WebFOCUS_WFI/apps

to

c

C:/ibi/WebFOCUS_WFI/app1

it also wrote out the APPROOT entry in the odd looking way.

I prefer that it just is a real path name that's applicable to the OS you're on. Maybe this is some attempt to escape the colon (:) for Unix people?

And this is probably unrelated but I noticed an odd line in tomcat's server.xml that was new in the integrated install that we don't normally have talking about special characters:

<Connector connectionTimeout="20000" maxPostSize="-1" port="25000" protocol="HTTP/1.1" redirectPort="25001" relaxedPathChars="[]|" relaxedQueryChars="[]|{}^`"<>" useBodyEncodingForURI="true"/>

That port - 25000 is what the WFI installer uses for tomcat's port instead of 8080. Just replace the 25000 with 8080 and the redirect from 25001 to 8443 to keep it normal in our minds...

The interesting part is the bit about 'relaxedQueryChars'. Haven't seen this before. I notice the in there. Just in case this has anything to do with the prior to the colon's we see in webfocus.cfg. Just thought I'd mention that it looks like something ibi added to tomcats server.xml. Not sure if that's a default.

Anyway, I see the renaming of the paths also in webfocus.cfg. Let us know what they say in your case.

Thanks for posting!

Link to comment
Share on other sites

I thought I should write down what I was able to find about the tomcat changes I saw in server.xml about relaxedQueryChars.

This setting is likely not related to the issues David and I see with the path names looking different than expected.

I am not using that setting currently in my tomcat setup, but here's what you'd see if you had a problem and need to think about adding it to your server.xml:

"

java.lang.IllegalArgumentException: Invalid character found in the request target. The valid characters are defined in RFC 7230 and RFC 3986

"

A more thorough description of someone hitting this issue is here:

[MGNLTOMCAT-6] Tomcat 9 less tolerant on special characters (compared to Tomcat 8) - Magnolia - Issue tracker (magnolia-cms.com)

Tomcat docs on the 'relaxed' settings are here:

Apache Tomcat 9 Configuration Reference (9.0.69) - The HTTP Connector

See the relaxedPathChars setting too. Both are similar.

To summarize, if you're having a problem where you might need to add these settings, it looks like you'll see a pretty obvious error message in your logs. If you'd like to set your relaxed settings to the default WebFOCUS integrated install settings, the strings to use are shown in my post above.

Link to comment
Share on other sites

I mentioned I would provide an update after I opened a case.

Opened a case with upgrade from 82 to 91 issue

Opened a new case with 9.1 issues

Told the following

This seems to be a general problem in 910 with any settings updated in the admin console that includes a slash or a backwards slash

We corrected the problems we found manually editing the affected files.

We are doing more testing

Link to comment
Share on other sites

  • 2 weeks later...

Did this issue effect the functionality of WF after the in-place upgrade? Did the upgrade corrupt the configuration files? Or, after the upgrade, when using the Admin Console to make changes the configuration files are corrupted? So, is the work around to make changes in a text editor not the Admin Console and wait for the issue to be resolved in a later Service Pack or version?

Link to comment
Share on other sites

Here is what we found out.

A clean install works fine. Mainly because nothing touched in a file called webfocus.cfg. This is only created when you go into admin console and add things like CM file locations.

It became evident that any upgrade would not work. Mainly since the install process takes the webfocus.cfg file and modifies it.

It is the editing by the admin console of the webfocus.cfg that corrupts the file.

One can manually edit the file and fix the syntax and it will work.

Word of warning any / or is messed up in the webfocus.cfg file by the admin console.

So avoid it.

Once the webfocus.cfg file is manually fixed, it works fine.

The case I opened has flagged this as a defect and I am told it will be fixed in the next 9.1 service pack or 9.2

Since there is no warning on the tibco site I wanted people to know what I encountered

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...