Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Hi guys Ive been getting this error for quite a while start...


Toby Mills

Recommended Posts

I took it out of my CLMs today and no more errors.

I havent removed it yet from the real reporting servers as I hope to figure out how to make it work.

FYI it worked for me to comment out the odin.cfg like this:

;-- Commenting out HyperStage per IBI case. Not to be used on CLM machines.

;-- ;HyperStage Database Server

;-- NODE = HSSU

;-- BEGIN

;-- PROTOCOL = TCP

;-- CLASS = HSSERVER

;-- END

I just copied a comment from the top of the file to try that syntax. Seems okay.

Link to comment
Share on other sites

Hi guys

Ive been getting this error for quite a while starting in 8207.27 I opened a case about it and thought Id put up the instructions for disabling Hyperstage.

First, I think this is an issue that surfaces when you go to the Golden Key for licensing if you havent been using Hyperstage before.

The case summary says:

 

Assisted customer with issues related to all server installs having HYPERSTAGE. Cluster manager Server should not have HYPErSTAGE configured. also, having Hyperstage on a shared drive is not recommended and should not be done. The WebFOCUS server accessing Hyperstage do not all need Hyperstage configured on them, the HS adapter can be added to access the HS data.

 

We dont really need Hyperstage so I asked how to turn it off.

The answer was that, at present, theres no easy way to turn it off. You need to comment out or remove lines from edaserv.cfg, odin.cfg and edasprof.prf. Sounds like theyre considering making this easier in the future.

Im about to try this to stop this error popping up in my server logs.

 

For the customer to remove HS from the CLMs the following must be removed and/or commented out:

edaserve.cfg

hypg_access = y

hypg_data = [C:ClusterStorageVolume1ibiHyperstagePG](file:///C:/ClusterStorage/Volume1/ibi/HyperstagePG)

hypg_home = [D:ibisrv82homehs](file:///D:/ibi/srv82/home/hs)

hypg_tools = [D:ibisrv82homehsbin](file:///D:/ibi/srv82/home/hs/bin)

odin.cfg:

;HyperStage Database Server

NODE = HSSU

BEGIN

PROTOCOL = TCP

CLASS = HSSERVER

END

edasprof.prf:

ENGINE SQLHYPG SET BULKLOAD ON

ENGINE SQLHYPG SET CONNECTION_ATTRIBUTES CON1 jdbc:postgresql://localhost:8124/webfocus/srvadmin,

For the edaserve.cfg and the odin.cfg if editing from the console it will require a restart for each, or you can edit the files manually and then restart the reporting server to implement all at one.

 

Extra add on - I presume we also need to remove this command from edasprof.prf since it references the adapter weve commented out:

ENGINE INT SET ETL-TRG-DBMS SQLHYPG/CON1

Link to comment
Share on other sites

  • 1 year later...

As this issue was discussed well over a year ago, I want to check if it has been resolved, is there a way to disable Hyperstage as part of the install, I encountered this issue whenever I attempted to run a silent installation of tibco webfocus (8207.28.07_linux310_x86_64.tar). Although the installation step is completed, I get error with the configuration as it tries to configure Hyperstage that we don't currently need

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...