Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Set a default value in a reporting object


Erin Trotter
Go to solution Solved by David Beagan ,

Recommended Posts

Is it possible to set a default value in a reporting object.  I'm using WebFocus version 9.1.1.  I have some reports that I needed to load while I have the parameter panel in the background still processing.  I set the parameters in the reporting object as optional, but one in particular (year) I guess defaults to all in the reporting object when not selected.  I would like to default it to the latest year so that if a user clicks a report while the parameter panel is still loading, it does not pull in 5 years of data.  We don't even want to display this much data temporarily.

 

I tried to add -DEFAULTH &YEAR = '2024' in the preprocessing part.  It doesn't do anything.  I also have had no luck on finding any documentation on how this might be possible or much documentation on the reporting object at all beyond the basics of it

Link to comment
Share on other sites

  • Solution

In WebFOCUS 9.10, I created a reporting object, and then a report in the reporting object with a parameter &REGION.

image.thumb.png.f3a351a4dd8466dfb2ab9aeb8430af6a.png

In the reporting object's Preprocessing Other I put in a default for the parameter variable.

image.thumb.png.bf4939821ff916705101dccda5cac15c.png

When I run it I get the Prompt with Northeast filled in. And then can run the report from there.

Or if I change the Proprocessing to -DEFAULTH and run the reporting object then it runs and filter for Northeast.

I wonder if it could be a bug with your release of WebFOCUS or maybe you are using it in a different way.

 

 

 

 

  • Like 1
Link to comment
Share on other sites

15 hours ago, Erin Trotter said:

I tried to add -DEFAULTH &YEAR = '2024' in the preprocessing part.  It doesn't do anything.  I also have had no luck on finding any documentation on how this might be possible or much documentation on the reporting object at all beyond the basics of it

The "problem" is the DEFAULTthe H wil prevent any prompting - it stands for HIDDEN - so Davids sample should work perfect 

I create a sample video on Reporting Object and Designer a while back

https://youtu.be/ETFazfjhP38?si=GOiBrP32n4eRh8c3

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...