Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Required COM interface is not registered IAS_VC2012_8204m_WFSFILE SYSTEM FATAL eRROR.


Muhammad Asif 3

Recommended Posts

Hi Muhammad

Sounds like something in your registry is not set right. Assuming you have permission to make a registry change, you might try navigating down to C:ibiAppStudioxxbin and right click/run as admin on a file called:

thisfoci.bat

It will attempt to reset all your registry entries.

If you're running 2 versions of app studio, make sure you're in the right folder (like mine is ibiAppStudio91 but for a while I also had a ibiAppStudio82 folder structure when I was running both versions).

The general idea used to be that you should only run one version at a time even though you were allowed to have more than one version installed. You'd use the thisfoci.bat file to flip the registry entries to whichever version you wanted to run. I thought this was not an issue anymore, but figured I should mention it.

Hope that helps.

Toby

Link to comment
Share on other sites

  • 3 months later...

Hi Muhammad

Which version did you have trouble with? both?

I think you'll need to remember run thisfoci.bat (described above) for 81 prior to launching the 81 app studio, then to switch to 82, you have to go under the 82 bin folder and run thisfoci for 82 prior to launching 82.

Last thing I knew, for the 81/82 world, you needed to re-run thisfoci.bat when you changed releases on the same pc. I think this might have been improved in 9.x but I'm not sure about that.

If it's possible, you might need to uninstall / reinstall.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...