Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

Hello all I started the migration utilities but ran into err...


Naeem Sufi 3

Recommended Posts

Hello all

I started the migration utilities but ran into errors I am wondering can those utilities still work since WF 8 has been upgraded so many times Migration manual does not say anything about issues with direct migration to WF8.27 from wf7703

if the direct migration is not possible from WF77 to Wf827.28 which interim version will I need to migrate to

has anyone experienced this issue

I would appreciate if you can share your experience here

thanks

Link to comment
Share on other sites

Naeem. The migration utilities will allow you to migrate from 7.x (includes 7703) to 8207. Having said that, this is not a simple upgrade / migration - much more complex than a binary refresh. There are separate utilities for the WebFOCUS Client and ReportCaster. Last time I did this upgrade, it did require me to clean up the file-based WebFOCUS repository, basedir, and I had to install an interim version of ReportCaster because of some errors
Link to comment
Share on other sites

Thanks Ron the error I am getting is from mr7xto8xexport.bat it is giving Cant parse mrrepos.htm do you know what you had to do cleanup basedir , mrrepos.htm In the basedir I see there are backup folder Basedir created in the past, should I remove those from Basedir backup directory Thanks
Link to comment
Share on other sites

Naeem. How big is your basedir folder and how is your WebFOCUS Client security configured It looks like you are getting errors reading the basedir folder. Have you tried running the utility as an administrator I see you have an open case for this and maybe there is some confusion there as you are doing a migration, not an in-place upgrade
Link to comment
Share on other sites

Hi Ron

please see below

yes I am having issue with the basedir basedir export I ran the utility as a Admin but I still get the same error There were some backup folders in the basedir folder I moved those out but still getting error.

from the export log I am getting this error

2022-03-21 14:49:26,263] INFO ibfssystem - Persistence.createEntityManagerFactory created PU:WebFOCUSRepositoryPU

[2022-03-21 14:49:26,263] INFO IBFSEntityManagerFactory - Created EntityManagerFactory with the persistence unit name WebFOCUSRepositoryPU sucessully

[2022-03-21 14:49:26,263] ERROR ibfssystem - *********************************************

[2022-03-21 14:49:26,263] ERROR ibfssystem - *** Failed to loadCachedInfo Failed to connect to the repository DB. ***

java.lang.IllegalStateException: Failed to connect to the repository DB.

at com.ibi.ibfs.IBFSService.initEntityManagerFactory(IBFSService.java:746) ~[webfocus-applications.jar:8207.28.08]

at com.ibi.ibfs.IBFSService.loadCachedInfo(IBFSService.java:556) [webfocus-applications.jar:8207.28.08]

at com.ibi.ibfs.IBFSService.init(IBFSService.java:361) [webfocus-applications.jar:8207.28.08]

at com.ibi.ibfs.IBFSService.(IBFSService.java:353) [webfocus-applications.jar:8207.28.08]

at com.ibi.ibfs.IBFSService.getIBFSService(IBFSService.java:444) [webfocus-applications.jar:8207.28.08]

at com.ibi.ibfs.IBFSService.getIBFSService(IBFSService.java:419) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.getIBFSService(WFConvertRepository.java:669) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.init(WFConvertRepository.java:681) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.convertRepository(WFConvertRepository.java:754) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.(WFConvertRepository.java:536) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.getWFConvertRepository(WFConvertRepository.java:563) [webfocus-applications.jar:8207.28.08]

at com.ibi.applications.mrexport.WFConvertRepository.main(WFConvertRepository.java:575) [webfocus-applications.jar:8207.28.08]

[2022-03-21 14:49:26,263] ERROR ibfssystem - *********************************************

[2022-03-21 14:49:26,310] FATAL ibfssystem - com.ibi.ibfs.error.IBFSException: Internal IBFS error

[2022-03-21 14:49:26,325] DEBUG impex -

Starting Migration Export. Repository is at E:/ibi/WebFOCUS77/basedir

 

image.jpg692791 153 KB

Link to comment
Share on other sites

Ron I looked at mrrepos.htm it has links to domains I see those domain folders in the basedir is there any specific thing I should look for is there any template I can view and compare mrreopos.htm

I contacted support so far now answer from them on this export issue

Thanks

Link to comment
Share on other sites

Naeem. Sorry you are having this issue. I have been following your case with support.

The last migration I did from an older release was 76 to 8207 and I was able to run the mr7xto8xexport. But, I was migrating to an earlier release of 8207.

Talking to support, there is an issue using the migration utilities to migrate to 8207. I think this was likely introduced after the migration I did, related to the license changes in the WebFOCUS GA version.

There is a project to update the migration doc. The recommended solution and the change to the doc is to use the migration utilities to upgrade to version 8206 and then upgrade to either 8207 or 9

Sorry for the confusion and hope this helps

Link to comment
Share on other sites

Thanks Ron , Yes that migration manual does need to be updated . Though it mentions 7.* versions that can be migrated to 8207 and have you copy the mr and rc folders (from 8207) to WF7 utilities folder to use for migration ;

Here is what I found out

MR, RC folders in utilities folder in 8207 do not work with WF 7*.* file based repository

Manual does not even mention BID migration

Since Support person mentioned that we need to move to interim version 8206 so I had him send me migration folders (RC and MR) from 8206

Luckily I had saved my notes when I migrated 7.6 to 8.0 back in 2014 I think that came handy

Thanks all for your help

Link to comment
Share on other sites

That was interesting Naeem. I appreciate you digging in there to figure out what to do. I would have though it would have worked just fine. Hopefully theyve addressed this in version 9x. Not that many customers are still on 7x releases, but there are some who might like to upgrade.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...