Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

I am using version 7.7.03. I have an unique situation happen...


Deana Goeken

Recommended Posts

I am using version 7.7.03. I have an unique situation happening with 1 js grid. I use js grids extensively throughout my application

I have 2 sql columns in my datagrid, The first, Name, is defined as char(30)/A30 the other, Payroll Note is char(150)/A150. Payroll Note was originally varchar(max)/TX50. However, when this problem cropped up, I tried changing it to a smaller value as I have had issues with varchar(max) in the past and the max length of the current values is 100. This code was working prior to a push I did last week. This particular file was not actually modified, but was included in the push because the change impacted 70% of the remainder of my system so I deployed everything.

The properties for the columns in the grid are as follows. Name is the 2nd column and Payroll Note is the 16th column.

 

The column width for Payroll Note was originally 0. I have tried various values including 0, 30, and 150.

No matter what, I am not able to edit the Payroll Note. Name of course does not allow me to enter the cell in the grid since it is read only. I am able to click into Payroll Note. However, the existing value is cleared and nothing I type is entered. I have other non read only alpha columns which are 3 and 4 characters in length and can be modified within the grid.

As a work around, I tried creating a text field below the grid for data entry with an event to populate

Payroll Note in the grid upon change. The js function is below.

function chgPayRemark( ) {

var strRemark = document.PayForm.txtPayRemark.value;

var objDg = document.PayForm.dgPay;

objDg.CellSetText (15, 0, strRemark);

}

If I type anything, including just 1 space, the function always returns There are too many characters in your entry.

If I change objDg.CellSetText (15, currRow, strRemark); to objDg.CellSetText (1, currRow, strRemark), the value in the Name column is replaced with whatever I entered into the text box, unless I enter more than 30 characters.

Any suggestions would be greatly appreciated.

Thank you, Deana

Link to comment
Share on other sites

Deana - First thing I would try would be to delete and re-add the column. If you changed the format of the field associated with the column that could be the issue.

If that doesnt help please open a case and post your files including the CSS file we created with you.

Thanks

Mark Derwin

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...