Jump to content
The ibi Community has moved to a new platform: Please Sign In and choose Forgot Password to continue

I have a group of about 29 users who would like to view thei...


Casey Green

Recommended Posts

I have a group of about 29 users who would like to view their daily sales metrics in a report. I have everyones information and can filter on an individual sales rep by selecting his or her employee ID in the report filter. However, I want the reports to default to filter on the employee ID based on the users login ID (mostly so that the sales reps cant access other reps report numbers).

Is there a way that anyone knows of to pass a users login account ID as a parameter within a report

Thanks

Link to comment
Share on other sites

Casey

Jans response is correct but for some reason myibi cuts of html syntax so you need the word SET surrounded by carets < > before the IBIMR_user in your custom settings. You can also set up a trusted connection between the WebFOCUS client and reporting server which will also send the &IBIMR_user or &FOCSECUSER. To do that your admiistrator will have to use the client administration console under Configuratioln / Reporting Servers / Server Connections / EDASERVE and choose Trusted under the Security

 

image.png930470 33.4 KB

 

Then on the Reporting Server Console under Access Control right mouse click on the Primary Security Provider and choose Properties and then change the trust_ext from N to Y and save

 

image.png800585 33.3 KB

Link to comment
Share on other sites

So Ive run into a hurdle. It looks like &FOCSECUSER is returning the user ID but it is only successfully being passed through when the user has admin priviledges. Ive made sure that the connection between WebFocus and the reporting server is trusted and is passing the user ID and their groups but &FOCSECUSER still seems to not be returning anything. Is there a permissions setting that Im missing to allow &FOCSECUSER to be passed to any user
Link to comment
Share on other sites

This issue has been solved. It looks like the usernames for the admin accounts (the ones I was testing with) have a different prefix than the everyday user. I was substringing &FOCSECUSER to remove the prefix but it was removing the entire string for non-admin users!
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
  • Create New...